aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/shell.nix b/shell.nix
index 16aa3fb..80ef0e4 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,5 +1,8 @@
with import <nixpkgs> {};
-mkShell {
- inherit (import ./default.nix {}) buildInputs nativeBuildInputs;
+let
+ default = import ./default.nix {};
+in mkShell {
+ inherit (default) buildInputs;
+ nativeBuildInputs = default.nativeBuildInputs ++ [ crate2nix ];
}