aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authortilpner2020-09-10 22:04:26 +0200
committertilpner2020-09-10 22:05:25 +0200
commit124e48e238a19c03d7434f7f0e6fe3ef1cfdcfa6 (patch)
treefef0a4b71e40537d01c41df78e62dfa712b69fa0 /shell.nix
parent30d8303badb0718c35ecc97334b9d7a4fc264ce6 (diff)
downloadrpb-s3-124e48e238a19c03d7434f7f0e6fe3ef1cfdcfa6.tar.gz
rpb-s3-124e48e238a19c03d7434f7f0e6fe3ef1cfdcfa6.tar.xz
rpb-s3-124e48e238a19c03d7434f7f0e6fe3ef1cfdcfa6.zip
Update to async, smol 1.0
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/shell.nix b/shell.nix
index 16aa3fb..80ef0e4 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,5 +1,8 @@
with import <nixpkgs> {};
-mkShell {
- inherit (import ./default.nix {}) buildInputs nativeBuildInputs;
+let
+ default = import ./default.nix {};
+in mkShell {
+ inherit (default) buildInputs;
+ nativeBuildInputs = default.nativeBuildInputs ++ [ crate2nix ];
}