aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml22
1 files changed, 11 insertions, 11 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 95f33cd..4705d98 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -5,29 +5,29 @@ authors = ["tilpner"]
edition = "2018"
[dependencies]
-smol = "1.0"
-async-compat = "0.1"
-itertools = "0.9"
-rand = "0.7"
-bytes = "0.5"
+smol = "1"
+async-compat = "0.2"
+itertools = "0.11"
+rand = "0.8"
+bytes = "1.5"
serde = "1.0"
serde_derive = "1.0"
-config = "0.10"
-xdg = "2.2.0"
+config = "0.13"
+xdg = "2.5"
structopt = "0.3"
mime_guess = "2.0"
futures = "0.3"
-rusoto_core = "0.45"
-rusoto_s3 = "0.45"
+rusoto_core = "0.48"
+rusoto_s3 = "0.48"
-syntect = "4.2"
+syntect = "5"
tinytemplate = "1.1"
[profile.release]
opt-level = 3
debug = false
-lto = true
+lto = "thin"
incremental = false