aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authortilpner2023-10-15 17:22:07 +0200
committertilpner2023-10-15 17:22:07 +0200
commit61083d614962dfeb69fdf767c5b0466b6efd413c (patch)
tree41643de13ad83da600f1a4aa814f04756a63d23f /Cargo.toml
parent0494c6341a9a34323bd68323a59c2152d4cc4a17 (diff)
downloadrpb-s3-master.tar.gz
rpb-s3-master.tar.xz
rpb-s3-master.zip
Update dependencies, add flakeHEADmaster
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml22
1 files changed, 11 insertions, 11 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 95f33cd..4705d98 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -5,29 +5,29 @@ authors = ["tilpner"]
edition = "2018"
[dependencies]
-smol = "1.0"
-async-compat = "0.1"
-itertools = "0.9"
-rand = "0.7"
-bytes = "0.5"
+smol = "1"
+async-compat = "0.2"
+itertools = "0.11"
+rand = "0.8"
+bytes = "1.5"
serde = "1.0"
serde_derive = "1.0"
-config = "0.10"
-xdg = "2.2.0"
+config = "0.13"
+xdg = "2.5"
structopt = "0.3"
mime_guess = "2.0"
futures = "0.3"
-rusoto_core = "0.45"
-rusoto_s3 = "0.45"
+rusoto_core = "0.48"
+rusoto_s3 = "0.48"
-syntect = "4.2"
+syntect = "5"
tinytemplate = "1.1"
[profile.release]
opt-level = 3
debug = false
-lto = true
+lto = "thin"
incremental = false