aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..76c11cf
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,19 @@
+let
+ overlay = self: super: rec {
+ buildRustCrateHelpers = self.callPackage ./buildRustCrateHelpers.nix {};
+
+ carnix-cross-test = self.callPackage hello/Cargo.nix {
+ cratesIO = self.callPackage hello/crates-io.nix { };
+ };
+
+ rustHello = carnix-cross-test.hello {};
+ };
+
+ nixpkgs = import (builtins.fetchTarball https://nixos.org/channels/nixos-unstable/nixexprs.tar.xz) {
+ overlays = [ overlay ];
+ };
+in {
+ inherit (nixpkgs.pkgsCross.aarch64-multiplatform)
+ hello
+ rustHello;
+}