aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authortilpner2018-09-25 15:58:57 +0200
committertilpner2018-09-25 15:58:57 +0200
commit040ec873821d23e168a59b7ee21697fe0af5bb4c (patch)
tree1c720f0a4c54ba76799ecfa3716821f7e95950e4 /default.nix
downloadcarnix-cross-040ec873821d23e168a59b7ee21697fe0af5bb4c.tar.gz
carnix-cross-040ec873821d23e168a59b7ee21697fe0af5bb4c.tar.xz
carnix-cross-040ec873821d23e168a59b7ee21697fe0af5bb4c.zip
Initial commit
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..76c11cf
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,19 @@
+let
+ overlay = self: super: rec {
+ buildRustCrateHelpers = self.callPackage ./buildRustCrateHelpers.nix {};
+
+ carnix-cross-test = self.callPackage hello/Cargo.nix {
+ cratesIO = self.callPackage hello/crates-io.nix { };
+ };
+
+ rustHello = carnix-cross-test.hello {};
+ };
+
+ nixpkgs = import (builtins.fetchTarball https://nixos.org/channels/nixos-unstable/nixexprs.tar.xz) {
+ overlays = [ overlay ];
+ };
+in {
+ inherit (nixpkgs.pkgsCross.aarch64-multiplatform)
+ hello
+ rustHello;
+}