aboutsummaryrefslogtreecommitdiff
path: root/profiles/restrict.nix
diff options
context:
space:
mode:
Diffstat (limited to 'profiles/restrict.nix')
-rw-r--r--profiles/restrict.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/profiles/restrict.nix b/profiles/restrict.nix
new file mode 100644
index 0000000..d751022
--- /dev/null
+++ b/profiles/restrict.nix
@@ -0,0 +1,26 @@
+{ ffLib }: {
+ policies = {
+ DisableProfileImport = true;
+ DisableProfileRefresh = true;
+
+ DisableMasterPasswordCreation = true;
+ DisableFeedbackCommands = true;
+ DisableFirefoxAccounts = true;
+ DisableFormHistory = true;
+ DisablePasswordReveal = true;
+
+ DontCheckDefaultBrowser = true;
+
+ DisableSecurityBypass = {
+ InvalidCertificate = true;
+ SafeBrowsing = false;
+ };
+
+ ExtensionSettings."*" = {
+ blocked_install_message = "Installation von Erweiterungen ist nicht zugelassen.";
+ install_sources = ["https://addons.mozilla.org/"];
+ installation_mode = "blocked";
+ allowed_types = ["extension"];
+ };
+ };
+}