aboutsummaryrefslogtreecommitdiff
path: root/profiles/restrict.nix
diff options
context:
space:
mode:
authortilpner2020-03-06 16:05:01 +0100
committertilpner2020-03-06 16:05:01 +0100
commit5014c0ed2160393fb787b585127bce8f27fda722 (patch)
treeb01c547725982c5ed866683c1b865381736653f8 /profiles/restrict.nix
parentedd25555261c17f74580245b8305cf7edefa4267 (diff)
downloadfirefox-profiles-5014c0ed2160393fb787b585127bce8f27fda722.tar.gz
firefox-profiles-5014c0ed2160393fb787b585127bce8f27fda722.tar.xz
firefox-profiles-5014c0ed2160393fb787b585127bce8f27fda722.zip
Separate policy into smaller modules
Diffstat (limited to 'profiles/restrict.nix')
-rw-r--r--profiles/restrict.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/profiles/restrict.nix b/profiles/restrict.nix
new file mode 100644
index 0000000..d751022
--- /dev/null
+++ b/profiles/restrict.nix
@@ -0,0 +1,26 @@
+{ ffLib }: {
+ policies = {
+ DisableProfileImport = true;
+ DisableProfileRefresh = true;
+
+ DisableMasterPasswordCreation = true;
+ DisableFeedbackCommands = true;
+ DisableFirefoxAccounts = true;
+ DisableFormHistory = true;
+ DisablePasswordReveal = true;
+
+ DontCheckDefaultBrowser = true;
+
+ DisableSecurityBypass = {
+ InvalidCertificate = true;
+ SafeBrowsing = false;
+ };
+
+ ExtensionSettings."*" = {
+ blocked_install_message = "Installation von Erweiterungen ist nicht zugelassen.";
+ install_sources = ["https://addons.mozilla.org/"];
+ installation_mode = "blocked";
+ allowed_types = ["extension"];
+ };
+ };
+}