aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix26
1 files changed, 2 insertions, 24 deletions
diff --git a/default.nix b/default.nix
index 9314826..4a2d43d 100644
--- a/default.nix
+++ b/default.nix
@@ -1,25 +1,3 @@
-{ pkgs ? import <nixpkgs> {} }:
-with builtins;
-with pkgs;
+{ pkgs ? import <nixpkgs> {}, callPackage ? pkgs.callPackage }:
-rustPlatform.buildRustPackage rec {
- pname = "rpb-s3";
- version = "0.1.0";
-
- ignore = map toString [
- ./target
- ];
- src = filterSource (path: type: !elem path ignore) ./.;
-
- nativeBuildInputs = [ rustc cargo pkgconfig ];
- buildInputs = [ openssl ];
-
- RUST_BACKTRACE = "1";
- cargoSha256 = "1xk364zx477jrpxn5lfzczlqg2x781g1l18kxcfxbi68bjkp8lri";
-
- postInstall = ''
- ln -s $out/bin/rpb-s3 $out/bin/pb
- '';
-
- doCheck = false;
-}
+(callPackage ./Cargo.nix {}).rootCrate.build