aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authortilpner2019-05-03 12:19:25 +0200
committertilpner2019-05-03 12:19:25 +0200
commit98976de4679b8be1024a69aff9fd304ffc1054d8 (patch)
tree092332217ac829af77b2e0f5c60d456c3de6134e /default.nix
parent35f5424d81e687096c7b7bd60f839deeb5e7f876 (diff)
downloadrpb-s3-98976de4679b8be1024a69aff9fd304ffc1054d8.tar.gz
rpb-s3-98976de4679b8be1024a69aff9fd304ffc1054d8.tar.xz
rpb-s3-98976de4679b8be1024a69aff9fd304ffc1054d8.zip
Add rest of project
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..fa42710
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,25 @@
+{ pkgs ? import <nixpkgs> {} }:
+with builtins;
+with pkgs;
+
+rustPlatform.buildRustPackage rec {
+ pname = "rpb-s3";
+ version = "0.1.0";
+
+ ignore = map toString [
+ ./target
+ ];
+ src = filterSource (path: type: !elem path ignore) ./.;
+
+ nativeBuildInputs = [ rustc cargo pkgconfig ];
+ buildInputs = [ openssl ];
+
+ RUST_BACKTRACE = "1";
+ cargoSha256 = "0hazg86j3c7fsc9fpdi34wy782xznljwhpmnz5ah5ppwc7gxyxfb";
+
+ postInstall = ''
+ ln -s $out/bin/rpb-s3 $out/bin/pb
+ '';
+
+ doCheck = false;
+}