aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authortilpner2020-09-10 22:04:26 +0200
committertilpner2020-09-10 22:05:25 +0200
commit124e48e238a19c03d7434f7f0e6fe3ef1cfdcfa6 (patch)
treefef0a4b71e40537d01c41df78e62dfa712b69fa0 /Cargo.toml
parent30d8303badb0718c35ecc97334b9d7a4fc264ce6 (diff)
downloadrpb-s3-124e48e238a19c03d7434f7f0e6fe3ef1cfdcfa6.tar.gz
rpb-s3-124e48e238a19c03d7434f7f0e6fe3ef1cfdcfa6.tar.xz
rpb-s3-124e48e238a19c03d7434f7f0e6fe3ef1cfdcfa6.zip
Update to async, smol 1.0
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml29
1 files changed, 16 insertions, 13 deletions
diff --git a/Cargo.toml b/Cargo.toml
index bcd342e..95f33cd 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,27 +1,30 @@
[package]
name = "rpb-s3"
version = "0.1.0"
-authors = ["till"]
+authors = ["tilpner"]
edition = "2018"
[dependencies]
-itertools = "0.8.0"
-rand = "0.6.5"
+smol = "1.0"
+async-compat = "0.1"
+itertools = "0.9"
+rand = "0.7"
+bytes = "0.5"
-serde = "1.0.82"
-serde_derive = "1.0.82"
-config = "0.9.1"
+serde = "1.0"
+serde_derive = "1.0"
+config = "0.10"
xdg = "2.2.0"
-structopt = "0.2.14"
+structopt = "0.3"
-mime_guess = "1.8.7"
+mime_guess = "2.0"
-futures = "0.1.25"
-rusoto_core = "0.36.0"
-rusoto_s3 = "0.36.0"
+futures = "0.3"
+rusoto_core = "0.45"
+rusoto_s3 = "0.45"
-syntect = "3.2.0"
-tinytemplate = "1.0.1"
+syntect = "4.2"
+tinytemplate = "1.1"
[profile.release]
opt-level = 3