aboutsummaryrefslogtreecommitdiff
path: root/hello/Cargo.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hello/Cargo.nix')
-rw-r--r--hello/Cargo.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/hello/Cargo.nix b/hello/Cargo.nix
new file mode 100644
index 0000000..4db6737
--- /dev/null
+++ b/hello/Cargo.nix
@@ -0,0 +1,26 @@
+# Generated by carnix 0.8.5: /home/till/.cargo/bin/carnix nix --src ./.
+{ lib, buildPlatform, buildRustCrate, buildRustCrateHelpers, cratesIO, fetchgit }:
+with buildRustCrateHelpers;
+let inherit (lib.lists) fold;
+ inherit (lib.attrsets) recursiveUpdate;
+in
+let crates = cratesIO // rec {
+ crates.hello."0.1.0" = deps: { features?(features_.hello."0.1.0" deps {}) }: buildRustCrate {
+ crateName = "hello";
+ version = "0.1.0";
+ authors = [ "till" ];
+ src = ./.;
+ };
+ features_.hello."0.1.0" = deps: f: updateFeatures f (rec {
+ hello."0.1.0".default = (f.hello."0.1.0".default or true);
+ }) [];
+
+
+
+}; in
+
+rec {
+ hello = crates.crates.hello."0.1.0" deps;
+ __all = [ (hello {}) ];
+ deps.hello."0.1.0" = {};
+}