aboutsummaryrefslogtreecommitdiff
path: root/profiles/noUpdates.nix
diff options
context:
space:
mode:
Diffstat (limited to 'profiles/noUpdates.nix')
-rw-r--r--profiles/noUpdates.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/profiles/noUpdates.nix b/profiles/noUpdates.nix
new file mode 100644
index 0000000..67cdb43
--- /dev/null
+++ b/profiles/noUpdates.nix
@@ -0,0 +1,25 @@
+{ ffLib }: {
+ policies = {
+ DisableAppUpdate = true;
+ DisableSystemAddonUpdate = true;
+ ExtensionUpdate = false;
+
+ Preferences = ffLib.flattenAttrs {
+ app.update.auto = false;
+ browser.search.update = false;
+ };
+ };
+
+ preferences = {
+ # try really hard to prevent search engine resets, probably wrong
+ browser.search = {
+ update = false;
+ geoSpecificDefaults = false;
+ "geoSpecificDefaults.url" = "";
+ geoip.url = "";
+ suggest.enabled = false;
+ reset.enabled = false;
+ reset.whitelist = "";
+ };
+ };
+}