aboutsummaryrefslogtreecommitdiff
path: root/profiles/minimalConnections.nix
diff options
context:
space:
mode:
Diffstat (limited to 'profiles/minimalConnections.nix')
-rw-r--r--profiles/minimalConnections.nix19
1 files changed, 14 insertions, 5 deletions
diff --git a/profiles/minimalConnections.nix b/profiles/minimalConnections.nix
index 66c931b..0fd43fa 100644
--- a/profiles/minimalConnections.nix
+++ b/profiles/minimalConnections.nix
@@ -1,4 +1,13 @@
{ ffLib }: {
+ meta.description = ''
+ Prevent unnecessary connections while browsing.
+
+ This profile assumes:
+ - The user does not move the device into a network where it may be held captive
+ before agreeing to usage terms.
+ - We have otherwise blocked the installation of arbitrary extensions.
+ '';
+
# https://support.mozilla.org/en-US/kb/how-stop-firefox-making-automatic-connections
policies = {
CaptivePortal = false;
@@ -17,11 +26,11 @@
preferences = {
toolkit.telemetry = {
- enabled = false;
- server = "";
+ enabled = false;
+ server = "";
unified = false;
archive.enabled = false;
-
+
newProfilePing.enabled = false;
firstShutdownPing.enabled = false;
shutdownPing.enabled = false;
@@ -43,7 +52,7 @@
amoDetailsURL = "";
};
};
-
+
network = {
predictor = {
enable-prefetch = false;
@@ -55,7 +64,7 @@
};
services.settings.server = "";
-
+
# TODO: what exactly does this block?
services.blocklist.pinning.enabled = false;