aboutsummaryrefslogtreecommitdiff
path: root/profiles/safebrowsing.nix
diff options
context:
space:
mode:
authortilpner2020-04-05 20:48:13 +0200
committertilpner2020-04-05 20:51:20 +0200
commit58a4f76dcad054cac6d5624b6f95e23145c16ae1 (patch)
treec8411c894bb93e58674cf344385e4c383adf6318 /profiles/safebrowsing.nix
parent5014c0ed2160393fb787b585127bce8f27fda722 (diff)
downloadfirefox-profiles-58a4f76dcad054cac6d5624b6f95e23145c16ae1.tar.gz
firefox-profiles-58a4f76dcad054cac6d5624b6f95e23145c16ae1.tar.xz
firefox-profiles-58a4f76dcad054cac6d5624b6f95e23145c16ae1.zip
ocsp, safebrowsing: refactor to finer choices per topic
Diffstat (limited to 'profiles/safebrowsing.nix')
-rw-r--r--profiles/safebrowsing.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/profiles/safebrowsing.nix b/profiles/safebrowsing.nix
new file mode 100644
index 0000000..79f3c82
--- /dev/null
+++ b/profiles/safebrowsing.nix
@@ -0,0 +1,32 @@
+{ ffLib }: rec {
+ meta.description = ''
+ Safebrowsing is a feature meant to protect the user from malicious websites and downloads.
+
+ See:
+ - https://wiki.mozilla.org/Security/Safe_Browsing
+ - https://wiki.mozilla.org/Security/Application_Reputation
+ '';
+
+ disableDownloads.preferences = {
+ browser.safebrowsing = {
+ downloads = {
+ # TODO: does this do offline checks?
+ enabled = false;
+ remote = {
+ enabled = false;
+ url = "";
+ };
+ };
+ };
+ };
+
+ disablePhishing.preferences = {
+ browser.safebrowsing.phishing.enabled = false;
+ };
+
+ disableMalware.preferences = {
+ browser.safebrowsing.malware.enabled = false;
+ };
+
+ disableAll = ffLib.mergeProfiles [ disableDownloads disablePhishing disableMalware ];
+}