aboutsummaryrefslogtreecommitdiff
path: root/profiles/minimalConnections.nix
diff options
context:
space:
mode:
authortilpner2020-03-06 16:05:01 +0100
committertilpner2020-03-06 16:05:01 +0100
commit5014c0ed2160393fb787b585127bce8f27fda722 (patch)
treeb01c547725982c5ed866683c1b865381736653f8 /profiles/minimalConnections.nix
parentedd25555261c17f74580245b8305cf7edefa4267 (diff)
downloadfirefox-profiles-5014c0ed2160393fb787b585127bce8f27fda722.tar.gz
firefox-profiles-5014c0ed2160393fb787b585127bce8f27fda722.tar.xz
firefox-profiles-5014c0ed2160393fb787b585127bce8f27fda722.zip
Separate policy into smaller modules
Diffstat (limited to 'profiles/minimalConnections.nix')
-rw-r--r--profiles/minimalConnections.nix68
1 files changed, 68 insertions, 0 deletions
diff --git a/profiles/minimalConnections.nix b/profiles/minimalConnections.nix
new file mode 100644
index 0000000..66c931b
--- /dev/null
+++ b/profiles/minimalConnections.nix
@@ -0,0 +1,68 @@
+{ ffLib }: {
+ # https://support.mozilla.org/en-US/kb/how-stop-firefox-making-automatic-connections
+ policies = {
+ CaptivePortal = false;
+ DisableTelemetry = true;
+ NetworkPrediction = false;
+ SearchSuggestEnabled = false;
+
+ Preferences = ffLib.flattenAttrs {
+ extensions = {
+ blocklist.enabled = false;
+ getAddons.showPane = false;
+ htmlaboutaddons.recommendations.enabled = false;
+ };
+ };
+ };
+
+ preferences = {
+ toolkit.telemetry = {
+ enabled = false;
+ server = "";
+ unified = false;
+ archive.enabled = false;
+
+ newProfilePing.enabled = false;
+ firstShutdownPing.enabled = false;
+ shutdownPing.enabled = false;
+ shutdownPingSender.enabled = false;
+
+ # background hang reporting
+ bhrPing.enabled = false;
+ updatePing.enabled = false;
+ };
+
+ extensions = {
+ blocklist.enabled = false;
+ getAddons.showPane = false;
+ getAddons.cache.enabled = false;
+ htmlaboutaddons.recommendations.enabled = false;
+
+ abuseReport = {
+ url = "";
+ amoDetailsURL = "";
+ };
+ };
+
+ network = {
+ predictor = {
+ enable-prefetch = false;
+ prefetch-next = false;
+ };
+
+ # Prevent FF from establishing connections on mouse-hover
+ http.speculative-parallel-limit = 0;
+ };
+
+ services.settings.server = "";
+
+ # TODO: what exactly does this block?
+ services.blocklist.pinning.enabled = false;
+
+ # don't send single words to search engine
+ browser.fixup.dns_first_for_single_words = true;
+
+ beacon.enabled = false;
+ browser.send_pings = false;
+ };
+}