{ ffLib }: {
  policies = {
    DisableProfileImport = true;
    DisableProfileRefresh = true;

    DisableMasterPasswordCreation = true;
    DisableFeedbackCommands = true;
    DisableFirefoxAccounts = true;
    DisableFormHistory = true;   
    DisablePasswordReveal = true;

    DontCheckDefaultBrowser = true;

    DisableSecurityBypass = {
      InvalidCertificate = true;
      SafeBrowsing = false;
    };

    ExtensionSettings."*" = {
      blocked_install_message = "Installation von Erweiterungen ist nicht zugelassen.";
      install_sources = ["https://addons.mozilla.org/"];
      installation_mode = "blocked";
      allowed_types = ["extension"];
    };
  };
}