# This tries to create a good-enough search.json.mozlz4 file, but that
# is unsupported, undocumented, and probably going to break every other release.

{ pkgs, lib }:

with lib;
rec {
  mkSearchConfig = engines: {
    version = 1;
    buildID = "20200202170918";
    appVersion = "72.0.2";
    locale = "und"; # undetermined (?)
    visibleDefaultEngines = [ "qwant-junior" ];

    metaData.searchDefaultExpir = 1581600883568;

    inherit engines;
  };

  engines = {
    qwantjunior = {
      _name = "Qwant Junior";
      _shortName = "qwant-junior";
      _loadPath = "[other]addEngineWithDetails:qwantjunior@search.mozilla.org";
      description = "Qwant Junior";
    };
  };
}