aboutsummaryrefslogtreecommitdiff
path: root/profiles/disablePocket.nix
diff options
context:
space:
mode:
Diffstat (limited to 'profiles/disablePocket.nix')
-rw-r--r--profiles/disablePocket.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/profiles/disablePocket.nix b/profiles/disablePocket.nix
new file mode 100644
index 0000000..8014c6e
--- /dev/null
+++ b/profiles/disablePocket.nix
@@ -0,0 +1,21 @@
+{ config, lib, ... }: with lib; {
+ options.features.disablePocket = mkOption {
+ type = types.bool;
+ default = false;
+ description = ''
+ Pocket allows saving sites to an external services.
+ For some reason, it has been integrated into Firefox directly,
+ instead of being offered as an extension.
+ '';
+ };
+
+ config = mkIf config.features.disablePocket {
+ policies = {
+ DisablePocket = true;
+ };
+
+ preferences = {
+ extensions.pocket.enabled = false;
+ };
+ };
+}