aboutsummaryrefslogtreecommitdiff
path: root/profiles/disableLocation.nix
diff options
context:
space:
mode:
Diffstat (limited to 'profiles/disableLocation.nix')
-rw-r--r--profiles/disableLocation.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/profiles/disableLocation.nix b/profiles/disableLocation.nix
new file mode 100644
index 0000000..1592dbb
--- /dev/null
+++ b/profiles/disableLocation.nix
@@ -0,0 +1,22 @@
+{ config, lib, ff, ... }: with lib; {
+ options.features.disableLocation = mkOption {
+ type = types.bool;
+ default = false;
+ description = ''
+ Forbid requests for the users precise location.
+ The remote end will still be able to look up the users IP address in a database, for
+ an approximate location.
+ '';
+ };
+
+ config.policies = mkIf config.features.disableLocation {
+ Permissions.Location = {
+ BlockNewRequests = true;
+ Locked = true;
+ };
+
+ Preferences = ff.flattenAttrs {
+ geo.enabled = false;
+ };
+ };
+}