aboutsummaryrefslogtreecommitdiff
path: root/profiles/disableAccounts.nix
diff options
context:
space:
mode:
Diffstat (limited to 'profiles/disableAccounts.nix')
-rw-r--r--profiles/disableAccounts.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/profiles/disableAccounts.nix b/profiles/disableAccounts.nix
new file mode 100644
index 0000000..b074b39
--- /dev/null
+++ b/profiles/disableAccounts.nix
@@ -0,0 +1,18 @@
+{ config, lib, ... }: with lib; {
+ options.features.disableAccounts = mkOption {
+ type = types.bool;
+ default = false;
+ description = ''
+ Disable Firefox Accounts.
+
+ This may inconvenience users who already use them on other devices,
+ but if we otherwise prevent the local storage of browsing information,
+ it would be inconsistent to let the user sign in and potentionally
+ store that same information remotely.
+ '';
+ };
+
+ config.preferences = mkIf config.features.disableAccounts {
+ identity.fxaccounts.enabled = false;
+ };
+}