aboutsummaryrefslogtreecommitdiff
path: root/profiles/trackingprotection.nix
diff options
context:
space:
mode:
authortilpner2020-06-15 09:53:06 +0200
committertilpner2020-06-15 09:53:06 +0200
commit367b0c114f38d5c332f5ee971ad13dd69e302dec (patch)
treeec0c5ee3e7e1f0a30517599e51bd0c8172635158 /profiles/trackingprotection.nix
parent2992d92e6ce0d7c96ccded0747d8815d8cfed956 (diff)
downloadfirefox-profiles-367b0c114f38d5c332f5ee971ad13dd69e302dec.tar.gz
firefox-profiles-367b0c114f38d5c332f5ee971ad13dd69e302dec.tar.xz
firefox-profiles-367b0c114f38d5c332f5ee971ad13dd69e302dec.zip
WIP towards module based configuration
Diffstat (limited to 'profiles/trackingprotection.nix')
-rw-r--r--profiles/trackingprotection.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/profiles/trackingprotection.nix b/profiles/trackingprotection.nix
new file mode 100644
index 0000000..f729df2
--- /dev/null
+++ b/profiles/trackingprotection.nix
@@ -0,0 +1,7 @@
+{ config, lib, ... }: {
+ options.trackingProtection.disableAll =
+ lib.mkEnableOption "Disable all inbuilt tracking protection";
+
+ config.preferences.browser.contentblocking.enabled =
+ lib.mkIf config.trackingProtection.disableAll false;
+}