aboutsummaryrefslogtreecommitdiff
path: root/profiles/disableStudies.nix
diff options
context:
space:
mode:
authortilpner2020-06-15 09:53:06 +0200
committertilpner2020-06-15 09:53:06 +0200
commit367b0c114f38d5c332f5ee971ad13dd69e302dec (patch)
treeec0c5ee3e7e1f0a30517599e51bd0c8172635158 /profiles/disableStudies.nix
parent2992d92e6ce0d7c96ccded0747d8815d8cfed956 (diff)
downloadfirefox-profiles-367b0c114f38d5c332f5ee971ad13dd69e302dec.tar.gz
firefox-profiles-367b0c114f38d5c332f5ee971ad13dd69e302dec.tar.xz
firefox-profiles-367b0c114f38d5c332f5ee971ad13dd69e302dec.zip
WIP towards module based configuration
Diffstat (limited to 'profiles/disableStudies.nix')
-rw-r--r--profiles/disableStudies.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/profiles/disableStudies.nix b/profiles/disableStudies.nix
new file mode 100644
index 0000000..b401fe0
--- /dev/null
+++ b/profiles/disableStudies.nix
@@ -0,0 +1,25 @@
+{ config, lib, ... }: with lib; {
+ options.features.disableStudies = mkOption {
+ type = types.bool;
+ default = false;
+ description = ''
+ Firefox Shield Studies are meant to allow Mozilla to perform A/B testing
+ on Firefox users.
+ Studies have been used in the past to introduce surprising behaviour [1],
+ and we may want to prevent that from happening to our users.
+
+ [1]: https://blog.mozilla.org/firefox/update-looking-glass-add/
+ https://mozilla.github.io/normandy/user/end_user_interaction.html#opt-out-preference
+ '';
+ };
+
+ config = mkIf config.features.disableStudies {
+ policies = {
+ DisableFirefoxStudies = true;
+ };
+
+ preferences = {
+ app.shield.optoutstudies.enabled = false;
+ };
+ };
+}